This version of MobileFrontend requires MediaWiki 1.23, you have 1.23.0. You can download a more appropriate version from https://www.mediawiki.org/wiki/Special:ExtensionDistributor/MobileFrontend